summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric@igalia.com>2022-11-03 10:13:16 +0000
committerMarge Bot <emma+marge@anholt.net>2023-02-23 09:42:46 +0000
commitfbd644c59d9868fd8417d5ab32912e893fab9c1b (patch)
tree4fb962e51e76198236920697e032949527088e81 /src/egl/meson.build
parentf059213f5dd510c22b1e0af102be6984aa715038 (diff)
meson: replace vk_wsi_args with dependencies to let meson take care of transitivity
Signed-off-by: Eric Engestrom <eric@igalia.com> Reviewed-by: Erik Faye-Lund <erik.faye-lund@collabora.com> Reviewed-by: Yonggang Luo <luoyonggang@gmail.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/19497>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 95d64c3e3a9..0a351bb687d 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -95,6 +95,7 @@ if with_dri2
)
files_egl += sha1_h
deps_for_egl += idep_xmlconfig
+ deps_for_egl += idep_vulkan_wsi_defines
link_for_egl += libloader
incs_for_egl += inc_loader
incs_for_egl += inc_gallium
@@ -107,9 +108,6 @@ if with_dri2
'drivers/dri2/platform_surfaceless.c',
)
- c_args_for_egl += vk_wsi_args
- cpp_args_for_egl += vk_wsi_args
-
if with_platform_x11
files_egl += files('drivers/dri2/platform_x11.c')
if with_dri3