summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2019-09-25 23:25:27 +0000
committerDylan Baker <dylan@pnwbakers.com>2019-09-25 23:25:27 +0000
commitfafd20f67dec9f5891838435ecde1dedb77ab742 (patch)
tree48d445d77515eff1b43fb3a89025d84d4e91ea51 /src/egl/meson.build
parent7e53bebcb5867039265b3c8201191b714f3cc347 (diff)
meson: fix logic for generating .pc files with old glvnd
We want to generate PC files for non-glvnd builds and for builds with old glvnd, but the current logic doesn't do that, it builds them unconditionally, and for GLES it builds the shared libraries, which is also not what we want. This does not generate .pc files for gles1 or gles2. Which it we weren't doing before either, making this not a regression but a return to status-quo.o Closes: https://gitlab.freedesktop.org/mesa/mesa/issues/1838 Fixes: 93df862b6affb6b8507e40601212a58012bfa873 ("meson: re-add incorrect pkg-config files with GLVND for backward compatibility") Reviewed-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build30
1 files changed, 16 insertions, 14 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 7038a68e955..7d738e2ebd1 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -176,21 +176,23 @@ libegl = shared_library(
# If using glvnd the pkg-config header should not point to EGL_mesa, it should
# point to EGL. glvnd is only available on unix like platforms so adding -l
# should be safe here
-if with_glvnd and glvnd_missing_pc_files
- _egl = '-L${libdir} -lEGL'
-else
- _egl = libegl
-endif
+if not with_glvnd or glvnd_missing_pc_files
+ if glvnd_missing_pc_files
+ _egl = '-L${libdir} -lEGL'
+ else
+ _egl = libegl
+ endif
-pkg.generate(
- name : 'egl',
- description : 'Mesa EGL Library',
- version : meson.project_version(),
- libraries : _egl,
- libraries_private: gl_priv_libs,
- requires_private : gl_priv_reqs,
- extra_cflags : gl_pkgconfig_c_flags,
-)
+ pkg.generate(
+ name : 'egl',
+ description : 'Mesa EGL Library',
+ version : meson.project_version(),
+ libraries : _egl,
+ libraries_private: gl_priv_libs,
+ requires_private : gl_priv_reqs,
+ extra_cflags : gl_pkgconfig_c_flags,
+ )
+endif
if with_tests and prog_nm.found()
if with_glvnd