summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorRoman Stratiienko <r.stratiienko@gmail.com>2020-12-15 16:50:19 +0200
committerMarge Bot <eric+marge@anholt.net>2021-06-30 16:50:44 +0000
commitf85d3113b2b73b351fc50b2089447787c7f9a731 (patch)
tree3980cd6ef41019f6e8acced768a64c05f8cd037f /src/egl/meson.build
parent5d3e64f10548035aa29e90d44fead6ba048220d9 (diff)
egl: android: add IMapper@4 metadata API buffer_info getter
Starting from Android-11 Google introduces generalized API to access buffer information. This API is a part of IMapper@4 HAL. Signed-off-by: Roman Stratiienko <r.stratiienko@gmail.com> Reviewed-by: Yiwei Zhang <zzyiwei@chromium.org> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/6045>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 055cfcf75fb..ab8f4e1fdbe 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -22,6 +22,7 @@ inc_egl = include_directories('.', 'main')
inc_egl_dri2 = include_directories('drivers/dri2')
c_args_for_egl = [asan_c_args]
+cpp_args_for_egl = []
link_for_egl = []
deps_for_egl = []
incs_for_egl = [inc_include, inc_src, inc_egl]
@@ -125,6 +126,11 @@ if with_dri2
if with_platform_android
deps_for_egl += dep_android
files_egl += files('drivers/dri2/platform_android.c')
+ if dep_android_mapper4.found()
+ files_egl += files('drivers/dri2/platform_android_mapper.cpp')
+ c_args_for_egl += '-DUSE_IMAPPER4_METADATA_API'
+ cpp_args_for_egl += ['-std=c++17', '-DUSE_IMAPPER4_METADATA_API']
+ endif
endif
elif with_platform_haiku
incs_for_egl += inc_haikugl
@@ -167,6 +173,7 @@ libegl = shared_library(
c_args_for_egl,
'-D_EGL_NATIVE_PLATFORM=_EGL_PLATFORM_@0@'.format(egl_native_platform.to_upper()),
],
+ cpp_args : [cpp_args_for_egl],
gnu_symbol_visibility : 'hidden',
include_directories : incs_for_egl,
link_with : [link_for_egl, libglapi],