summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorYonggang Luo <luoyonggang@gmail.com>2022-11-08 20:32:07 +0800
committerMarge Bot <emma+marge@anholt.net>2022-11-11 05:38:19 +0000
commitf03421702cc35059e4ead86839906ddfcf05bdc7 (patch)
tree2353a9fffdd350992213de82df9ce6b17e5df10e /src/egl/meson.build
parente5656f07c7a65b1d143684671cd8235af099a84c (diff)
meson: Refactoring shared gen_vs_module_defs_normal_command out
Cc: mesa-stable Signed-off-by: Yonggang Luo <luoyonggang@gmail.com> Reviewed-by: Jesse Natalie <jenatali@microsoft.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/19610>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index f1d77b64cc5..a7c6471ceb4 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -183,9 +183,7 @@ egl_def = custom_target(
'egl.def',
input: 'main/egl.def.in',
output : 'egl.def',
- command : [prog_python, gen_vs_module_defs_py,
- '--in_file', '@INPUT@', '--out_file', '@OUTPUT@',
- '--compiler_id', cc.get_argument_syntax(), '--cpu_family', host_machine.cpu_family()]
+ command : gen_vs_module_defs_normal_command,
)
libegl = shared_library(