summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorRoman Stratiienko <r.stratiienko@gmail.com>2023-07-27 21:42:44 +0300
committerMarge Bot <emma+marge@anholt.net>2024-01-10 14:09:23 +0000
commitefe12ae7ee1801d8d05c4069b793766b2f06cb7b (patch)
tree2ae81d2bd8ae74f6e39df74cc2a32334a0742579 /src/egl/meson.build
parentff82868a6013e665c14ce8b64baddc5e78019f84 (diff)
egl/android: Switch to generic buffer-info code
Switch to a new common buffer-info layer. After this change, the virgl fallback logic is changed, but it should work as well. Signed-off-by: Roman Stratiienko <r.stratiienko@gmail.com> Tested-by: Mauro Rossi <issor.oruam@gmail.com> Reviewed-by: Yiwei Zhang <zzyiwei@chromium.org> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/24374>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build7
1 files changed, 1 insertions, 6 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index b92c00f585a..8343bb6b953 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -133,13 +133,8 @@ if with_dri2
incs_for_egl += include_directories('wayland/wayland-drm')
endif
if with_platform_android
- deps_for_egl += dep_android
+ deps_for_egl += [dep_android, idep_u_gralloc]
files_egl += files('drivers/dri2/platform_android.c')
- if dep_android_mapper4.found()
- files_egl += files('drivers/dri2/platform_android_mapper.cpp')
- c_args_for_egl += '-DUSE_IMAPPER4_METADATA_API'
- cpp_args_for_egl += '-DUSE_IMAPPER4_METADATA_API'
- endif
endif
elif with_platform_haiku
c_args_for_egl += [