summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-07-22 14:50:15 +0100
committerEric Engestrom <eric@engestrom.ch>2019-08-03 00:08:37 +0000
commitd2d85b950d78c553b2694cda9ef0cc7bf9a0f737 (patch)
treeafdd28e30b66064b8b540a6e9d6d0ecbe27a6678 /src/egl/meson.build
parent8ddb38209d51c53d6e5792b04b97814dfce9bce6 (diff)
meson: replace libmesa_util with idep_mesautil
This automates the include_directories and dependencies tracking so that all users of libmesa_util don't need to add them manually. Next commit will remove the ones that were only added for that reason. Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Acked-by: Eric Anholt <eric@anholt.net> Tested-by: Vinson Lee <vlee@freedesktop.org>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index b433ccb7600..f81f85b7e74 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -165,9 +165,9 @@ libegl = shared_library(
'-D_EGL_NATIVE_PLATFORM=_EGL_PLATFORM_@0@'.format(egl_native_platform.to_upper()),
],
include_directories : incs_for_egl,
- link_with : [link_for_egl, libglapi, libmesa_util],
+ link_with : [link_for_egl, libglapi],
link_args : [ld_args_bsymbolic, ld_args_gc_sections],
- dependencies : [deps_for_egl, dep_dl, dep_libdrm, dep_clock, dep_thread],
+ dependencies : [deps_for_egl, dep_dl, dep_libdrm, dep_clock, dep_thread, idep_mesautil],
install : true,
version : egl_lib_version,
)