summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric@engestrom.ch>2022-08-22 21:03:15 +0100
committerMarge Bot <emma+marge@anholt.net>2022-08-24 22:13:19 +0000
commitc66622de3af4efc3717131c55a54b408bc7faade (patch)
treedd84ff37bb777e91167ad40caf5077a8761d21a7 /src/egl/meson.build
parent76bcf69e33b9452bdbc9c79e64ba4353dd57398a (diff)
meson: replace manual compiler flags with meson arguments
These would only have worked in GCC and Clang, which so far wasn't an issue, but let's clean it up anyway. Cc: mesa-stable Signed-off-by: Eric Engestrom <eric@engestrom.ch> Reviewed-by: Jesse Natalie <jenatali@microsoft.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/18190>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 6420f85fb74..f1d77b64cc5 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -23,6 +23,7 @@ inc_egl_dri2 = include_directories('drivers/dri2')
c_args_for_egl = [asan_c_args]
cpp_args_for_egl = []
+override_for_egl = []
link_for_egl = []
deps_for_egl = []
incs_for_egl = [inc_include, inc_src, inc_egl]
@@ -131,7 +132,8 @@ if with_dri2
if dep_android_mapper4.found()
files_egl += files('drivers/dri2/platform_android_mapper.cpp')
c_args_for_egl += '-DUSE_IMAPPER4_METADATA_API'
- cpp_args_for_egl += ['-std=c++17', '-DUSE_IMAPPER4_METADATA_API']
+ cpp_args_for_egl += '-DUSE_IMAPPER4_METADATA_API'
+ override_for_egl += 'cpp_std=c++17'
endif
endif
elif with_platform_haiku
@@ -194,6 +196,7 @@ libegl = shared_library(
'-D_EGL_NATIVE_PLATFORM=_EGL_PLATFORM_@0@'.format(egl_native_platform.to_upper()),
],
cpp_args : [cpp_args_for_egl],
+ override_options : override_for_egl,
gnu_symbol_visibility : 'hidden',
include_directories : incs_for_egl,
link_with : [link_for_egl, libglapi],