summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorSilvestrs Timofejevs <silvestrs.timofejevs@imgtec.com>2019-04-02 16:36:22 +0100
committerMarge Bot <emma+marge@anholt.net>2021-12-11 00:25:04 +0000
commitc02b75d22e6f3cdb82c4fbcb88e18d55aa9bb414 (patch)
tree939281501a7313d18dbc700d39263962410c3c85 /src/egl/meson.build
parentf927a5c3d28b2289223ea84445d8266d4f4f2ad2 (diff)
egl: add config debug printout
Feature to print out EGL returned configs for debug purposes. 'eglChooseConfig' and 'eglGetConfigs' debug information printout is enabled when the log level equals '_EGL_DEBUG'. The configs are printed, and if any of them are "chosen" they are marked with their index in the chosen configs array. v2: a) re-factor the code in line with review comments b) rename function _snprintfStrcat, split it out and put into the src/util/u_string.h, make it a separate patch. v3: remove unnecessary 'const' qualifiers from the function prototype v4: a) re-factor the code in line with review comments b) move util_strnappend from utils back to eglconfigdebug.c. In my opinion this function is the best way of achieving the desired result, so it still used but made private to eglconfigdebug.c. v5: a) drop unused parameter from function signature b) more const annotations c) directly access config parameters instead of going through _eglGetConfigKey Signed-off-by: Silvestrs Timofejevs <silvestrs.timofejevs@imgtec.com> Signed-off-by: Lucas Stach <l.stach@pengutronix.de> Reviewed-by: Eric Engestrom <eric@engestrom.ch> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/13705>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 65faf607705..315a95013f3 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -31,6 +31,8 @@ files_egl = files(
'main/eglapi.c',
'main/eglarray.c',
'main/eglarray.h',
+ 'main/eglconfigdebug.c',
+ 'main/eglconfigdebug.h',
'main/eglconfig.c',
'main/eglconfig.h',
'main/eglcontext.c',