summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-09-19 14:18:55 +0100
committerEric Engestrom <eric.engestrom@intel.com>2019-09-25 17:27:54 +0100
commit93df862b6affb6b8507e40601212a58012bfa873 (patch)
tree1c789af81c81d79f155067f25611664990f46a14 /src/egl/meson.build
parentdb2ca45102753f9af62d4fe339599a357239b781 (diff)
meson: re-add incorrect pkg-config files with GLVND for backward compatibility
This is a bit counter-intuitive, but the issue is that GLVND is broken in versions <= 1.1.1, so we need to keep wrongly providing these files to cover up their mistake, otherwise the rest of the world ends up broken. Suggested-by: Dylan Baker <dylan@pnwbakers.com> Cc: mesa-stable@lists.freedesktop.org Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build27
1 files changed, 17 insertions, 10 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 14aca2a2186..7038a68e955 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -173,18 +173,25 @@ libegl = shared_library(
version : egl_lib_version,
)
-if not with_glvnd
- pkg.generate(
- name : 'egl',
- description : 'Mesa EGL Library',
- version : meson.project_version(),
- libraries : libegl,
- libraries_private: gl_priv_libs,
- requires_private : gl_priv_reqs,
- extra_cflags : gl_pkgconfig_c_flags,
- )
+# If using glvnd the pkg-config header should not point to EGL_mesa, it should
+# point to EGL. glvnd is only available on unix like platforms so adding -l
+# should be safe here
+if with_glvnd and glvnd_missing_pc_files
+ _egl = '-L${libdir} -lEGL'
+else
+ _egl = libegl
endif
+pkg.generate(
+ name : 'egl',
+ description : 'Mesa EGL Library',
+ version : meson.project_version(),
+ libraries : _egl,
+ libraries_private: gl_priv_libs,
+ requires_private : gl_priv_reqs,
+ extra_cflags : gl_pkgconfig_c_flags,
+)
+
if with_tests and prog_nm.found()
if with_glvnd
egl_symbols = files('egl-glvnd-symbols.txt')