summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric@engestrom.ch>2020-02-05 22:58:23 +0000
committerMarge Bot <eric+marge@anholt.net>2020-02-06 00:19:13 +0000
commit76f300f2e498f101c58e182eac3ece11e527d297 (patch)
treed3f3163f9ea775717aeed8a87e7bbd9a2ad1a7cb /src/egl/meson.build
parent9595b23a45a6bcb7ee784e2c38085a8ea2e4620a (diff)
Revert "egl: put full path to libEGL_mesa.so in GLVND json"
This reverts commit 0021f7dc307f4852955359adb5ac2b7667e6d4ac. That commit had 2 issues: - I missed the `.0` from the filename, causing issues on Debian & Ubuntu platforms. - I didn't think about multilib/multi-arch systems, where we'd now need a separate json for each arch as they point to different libs. Reverting this commit for now, I'll try again later. Requested-by: Michel Dänzer <michel@daenzer.net> Closes: https://gitlab.freedesktop.org/mesa/mesa/issues/2466 Closes: https://gitlab.freedesktop.org/mesa/mesa/issues/2471 Closes: https://gitlab.freedesktop.org/mesa/mesa/issues/2480 Signed-off-by: Eric Engestrom <eric@engestrom.ch> Tested-by: Marge Bot <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/3726> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/3726>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build14
1 files changed, 2 insertions, 12 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index db34453ee9b..12d74ec37fa 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -152,18 +152,8 @@ else
deps_for_egl += dep_glvnd
files_egl += [g_egldispatchstubs_h, g_egldispatchstubs_c]
files_egl += files('main/eglglvnd.c', 'main/egldispatchstubs.c')
-
- egl_icd = custom_target(
- 'glvnd_icd',
- input : 'glvnd_icd.py',
- output : '50_mesa.json',
- command : [
- prog_python, '@INPUT@',
- '--lib-path', join_paths(get_option('prefix'), get_option('libdir')),
- '--out', '@OUTPUT@',
- ],
- build_by_default : true,
- install : true,
+ install_data(
+ 'main/50_mesa.json',
install_dir : join_paths(get_option('datadir'), 'glvnd', 'egl_vendor.d')
)
endif