summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-09-25 17:38:49 +0100
committerEric Engestrom <eric.engestrom@intel.com>2019-10-31 17:09:59 +0000
commit6e21dcc5a31634232660eff1a83052c2ebb4816c (patch)
tree0061d60279b43c9ed33929e31e115aef789e0093 /src/egl/meson.build
parent0f201e9dbc8711f61a692de50cf283a30fad3030 (diff)
meson: revert glvnd workaround
This effectively reverts MR !2112. Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build13
1 files changed, 2 insertions, 11 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 9c2c055c3eb..14aca2a2186 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -173,21 +173,12 @@ libegl = shared_library(
version : egl_lib_version,
)
-# If using glvnd the pkg-config header should not point to EGL_mesa, it should
-# point to EGL. glvnd is only available on unix like platforms so adding -l
-# should be safe here
-if not with_glvnd or not glvnd_has_headers_and_pc_files
- if not glvnd_has_headers_and_pc_files
- _egl = '-L${libdir} -lEGL'
- else
- _egl = libegl
- endif
-
+if not with_glvnd
pkg.generate(
name : 'egl',
description : 'Mesa EGL Library',
version : meson.project_version(),
- libraries : _egl,
+ libraries : libegl,
libraries_private: gl_priv_libs,
requires_private : gl_priv_reqs,
extra_cflags : gl_pkgconfig_c_flags,