summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2019-10-10 15:10:56 -0700
committerDylan Baker <dylan@pnwbakers.com>2019-11-05 16:44:41 +0000
commit5d085ad052aac1f35cef7b60c0e6ecad65a6807b (patch)
tree3da1ce328b740deac617383e4fc4f210b4c9d321 /src/egl/meson.build
parent9020f519d2434be33edd59b9205d6647db4472bb (diff)
meson: Add dep_glvnd to egl deps when building with glvnd
Otherwise if glvnd is not installed systemwide, but only in a prefix, it's headers wont be found. This happens because if it's headers are in /usr/include/ then another dependence will provide the necessary -I arguments and compilation will work. Fixes: 035ec7a2bb2d5e413ac945b8f012185a0e187d5e ("meson: Add support for EGL glvnd") Acked-by: Eric Engestrom <eric@engestrom.ch>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 14aca2a2186..1c1143f3418 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -1,4 +1,4 @@
-# Copyright © 2017 Intel Corporation
+# Copyright © 2017-2019 Intel Corporation
# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to deal
@@ -149,6 +149,7 @@ if not with_glvnd
else
egl_lib_name = 'EGL_mesa'
egl_lib_version = '0.0.0'
+ deps_for_egl += dep_glvnd
files_egl += [g_egldispatchstubs_h, g_egldispatchstubs_c]
files_egl += files('main/eglglvnd.c', 'main/egldispatchstubs.c')
install_data(