summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorYonggang Luo <luoyonggang@gmail.com>2021-12-03 20:51:58 +0800
committerMarge Bot <emma+marge@anholt.net>2022-04-19 19:38:47 +0000
commit4ead2f65799246a40fe3f2d45a494d0466c59735 (patch)
treedf5138fff79de4073408950ac760846c2fc22e45 /src/egl/meson.build
parent550975f2298bcfbf565009e23d784cd5169a2089 (diff)
win32: Fixes 32 bits visual studio module definition files by add script gen_vs_module_defs.py
Getting opengl32*.def consistence with Windows SDK. Getting osmesa.mingw.def's gl* functions consistence with Windows SDK. stw_* functions are cdecl, not stdcall, so there is no need mangling the symbol. Fixes egl.def for x86 d3d10sw: Move the place of d3d10_sw.def to d3d10_sw.def.in Fixes vulkan_lvp.def for x86 Fixes #5552 Remove stdcall-fixup Signed-off-by: Yonggang Luo <luoyonggang@gmail.com> Reviewed-by: Jesse Natalie <jenatali@microsoft.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/14041>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 315a95013f3..53044297322 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -177,6 +177,15 @@ else
)
endif
+egl_def = custom_target(
+ 'egl.def',
+ input: 'main/egl.def.in',
+ output : 'egl.def',
+ command : [prog_python, gen_vs_module_defs_py,
+ '--in_file', '@INPUT@', '--out_file', '@OUTPUT@',
+ '--compiler_id', cc.get_id(), '--cpu_family', host_machine.cpu_family()]
+)
+
libegl = shared_library(
egl_lib_name,
files_egl,
@@ -194,7 +203,7 @@ libegl = shared_library(
version : egl_lib_version,
soversion : egl_lib_soversion,
name_prefix : 'lib', # even on windows
- vs_module_defs : 'main/egl.def'
+ vs_module_defs : egl_def
)
if not with_glvnd