summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2022-08-26 11:01:29 +0200
committerMarge Bot <emma+marge@anholt.net>2023-05-03 16:09:09 +0000
commit47cd010931a48fcdf259ffcd455ca065f180adc3 (patch)
tree475f69ec26ffef9d62c402585c2b682531b52c90 /src/egl/meson.build
parent0b251d43622391cbffad4a4e748e41223b2344fe (diff)
wayland: generalize wayland-protocols code generation
Make it easy to add a new protocol to the list without duplicating logic. Signed-off-by: Simon Ser <contact@emersion.fr> Reviewed-by: Eric Engestrom <eric@igalia.com> Reviewed-by: Daniel Stone <daniels@collabora.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/22682>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build7
1 files changed, 2 insertions, 5 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index ac9a48e0990..013a93367d6 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -129,11 +129,8 @@ if with_dri2
deps_for_egl += [dep_wayland_client, dep_wayland_server, dep_wayland_egl_headers]
link_for_egl += libwayland_drm
files_egl += files('drivers/dri2/platform_wayland.c')
- files_egl += [
- linux_dmabuf_unstable_v1_protocol_c,
- linux_dmabuf_unstable_v1_client_protocol_h,
- wayland_drm_client_protocol_h,
- ]
+ files_egl += wp_files['linux-dmabuf-unstable-v1']
+ files_egl += [wayland_drm_client_protocol_h]
incs_for_egl += include_directories('wayland/wayland-drm')
endif
if with_platform_android