summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorErik Faye-Lund <erik.faye-lund@collabora.com>2023-02-08 09:34:34 +0100
committerMarge Bot <emma+marge@anholt.net>2023-02-15 18:35:14 +0000
commit29ffc7941042d697ca687be3ab408f18822301a4 (patch)
tree8dc5dbd4a15f68a49ed8a1c8ab1097f95f61fb3b /src/egl/meson.build
parent7ea85871fe7551d933948155b477a10a00548d8a (diff)
meson: don't pass vk wsi args where they don't belong
Only code that cares about Vulkan WSI should get the corresponding arguments passed. Otherwise, the Vulkan headers might end up including other headers that we don't have the correct dependencies passed for. So let's give those a dedicated variable, and only pass that where it's actually needed. Fixes: b39958a3a18 ("anv,nir: Move the ANV YCbCr lowering pass to common code") Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/8193 Reviewed-by: Yonggang Luo <luoyonggang@gmail.com> Reviewed-by: Adam Jackson <ajax@redhat.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/21185>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 948dcd90670..01fccf9912c 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -106,6 +106,10 @@ if with_dri2
'drivers/dri2/platform_device.c',
'drivers/dri2/platform_surfaceless.c',
)
+
+ c_args_for_egl += vk_wsi_args
+ cpp_args_for_egl += vk_wsi_args
+
if with_platform_x11
files_egl += files('drivers/dri2/platform_x11.c')
if with_dri3