summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorYonggang Luo <luoyonggang@gmail.com>2022-04-22 01:09:19 +0800
committerMarge Bot <emma+marge@anholt.net>2022-06-16 19:59:58 +0000
commit1173c0f33ac22955705192e489fb82759c152656 (patch)
treed42b72d0a547c4422096fc8af396ade6c1286988 /src/egl/meson.build
parent686e20afcd32cb80b96984c8eb4428e777fbce97 (diff)
meson: Using get_argument_syntax as the `--compiler_id` option for gen_vs_module_defs.py
Signed-off-by: Yonggang Luo <luoyonggang@gmail.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/17065>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 53044297322..be55ac7ab7f 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -183,7 +183,7 @@ egl_def = custom_target(
output : 'egl.def',
command : [prog_python, gen_vs_module_defs_py,
'--in_file', '@INPUT@', '--out_file', '@OUTPUT@',
- '--compiler_id', cc.get_id(), '--cpu_family', host_machine.cpu_family()]
+ '--compiler_id', cc.get_argument_syntax(), '--cpu_family', host_machine.cpu_family()]
)
libegl = shared_library(