summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-12-06 16:17:12 +0000
committerEric Engestrom <eric@engestrom.ch>2020-02-02 17:46:17 +0000
commit0021f7dc307f4852955359adb5ac2b7667e6d4ac (patch)
treec69dd2b5da2d236120323fc068b1c8211e352150 /src/egl/meson.build
parentd5fd8cd46eeedeabf8647c06489a755aea8f0080 (diff)
egl: put full path to libEGL_mesa.so in GLVND json
This is useful when installing to a non-standard path. glvnd_icd.py copied & adapted from src/intel/vulkan/anv_icd.py Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Acked-by: Matt Turner <mattst88@gmail.com> Tested-by: Marge Bot <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/3038> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/3038>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 12d74ec37fa..db34453ee9b 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -152,8 +152,18 @@ else
deps_for_egl += dep_glvnd
files_egl += [g_egldispatchstubs_h, g_egldispatchstubs_c]
files_egl += files('main/eglglvnd.c', 'main/egldispatchstubs.c')
- install_data(
- 'main/50_mesa.json',
+
+ egl_icd = custom_target(
+ 'glvnd_icd',
+ input : 'glvnd_icd.py',
+ output : '50_mesa.json',
+ command : [
+ prog_python, '@INPUT@',
+ '--lib-path', join_paths(get_option('prefix'), get_option('libdir')),
+ '--out', '@OUTPUT@',
+ ],
+ build_by_default : true,
+ install : true,
install_dir : join_paths(get_option('datadir'), 'glvnd', 'egl_vendor.d')
)
endif