summaryrefslogtreecommitdiff
path: root/src/egl/Makefile.am
diff options
context:
space:
mode:
authorNicolas Boichat <drinkcat@chromium.org>2016-04-28 18:41:38 +0800
committerEmil Velikov <emil.l.velikov@gmail.com>2016-05-23 13:23:39 +0100
commit27d713a004da1918d1c5699b077734eceb0ebd75 (patch)
treeabd33456d5f08ddbdd50f3b2764d3042bd6ec3c1 /src/egl/Makefile.am
parent960d854a9866be4e335dd20465342026f660fc78 (diff)
configure.ac: Add support for Android builds
Add support for EGL android platform. Also, detect when --host finishes with -android. In that case, we do not set _GNU_SOURCE, and define autoconf symbol HAVE_ANDROID, so that Android-specific workarounds can be applied. Signed-off-by: Nicolas Boichat <drinkcat@google.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com> [Emil Velikov: Rebase on top of HAVE_EGL_PLATFORM_NULL removal] Signed-off-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'src/egl/Makefile.am')
-rw-r--r--src/egl/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/egl/Makefile.am b/src/egl/Makefile.am
index 407cc69b53e..95ee6ccc496 100644
--- a/src/egl/Makefile.am
+++ b/src/egl/Makefile.am
@@ -84,6 +84,11 @@ AM_CFLAGS += -DHAVE_SURFACELESS_PLATFORM
dri2_backend_FILES += drivers/dri2/platform_surfaceless.c
endif
+if HAVE_EGL_PLATFORM_ANDROID
+AM_CFLAGS += -DHAVE_ANDROID_PLATFORM
+dri2_backend_FILES += drivers/dri2/platform_android.c
+endif
+
if HAVE_EGL_DRIVER_DRI2
AM_CFLAGS += \
-I$(top_srcdir)/src/loader \