summaryrefslogtreecommitdiff
path: root/src/egl/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2017-08-04 17:49:08 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2017-08-04 23:54:52 +0100
commit10e7c2c64d46da38d30d04a2c10c8c3cd5a30f7a (patch)
tree167cd089b54a9cd6040c19273ecd4619291c78a1 /src/egl/Makefile.am
parent6c530ad1160518d9f035da4aba5a9d4df7369972 (diff)
loader: rework xmlconfig dependency
Currently xmlconfig is conditionally used, only when --enable-dri is available. As the library has moved to src/util and has wider wisebase, this guard is no longer correct. Strictly speaking - it wasn't since the introduction of xmlconfig into st/nine a while ago. Unconditionally enable xmlconfig and drop the linking. As said before there's other users of the library, so depending on the configure options we will get multiple definitions of said symbols. NOTE: To avoid breaking other combinations, this commit adds the xmlconfig link to the required places - throughout gallium and the DRI loaders. Cc: Aaron Watry <awatry@gmail.com> Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Nicolai Hähnle <nicolai.haehnle@amd.com> Tested-by: Dieter Nützel <Dieter@nuetzel-hh.de>
Diffstat (limited to 'src/egl/Makefile.am')
-rw-r--r--src/egl/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/egl/Makefile.am b/src/egl/Makefile.am
index ecaf148aaec..bb8ec9745dd 100644
--- a/src/egl/Makefile.am
+++ b/src/egl/Makefile.am
@@ -120,8 +120,12 @@ libEGL_common_la_SOURCES += \
$(dri2_backend_FILES) \
$(dri3_backend_FILES)
-libEGL_common_la_LIBADD += $(top_builddir)/src/loader/libloader.la
-libEGL_common_la_LIBADD += $(DLOPEN_LIBS) $(LIBDRM_LIBS) $(CLOCK_LIB)
+libEGL_common_la_LIBADD += \
+ $(top_builddir)/src/loader/libloader.la \
+ $(top_builddir)/src/util/libxmlconfig.la \
+ $(DLOPEN_LIBS) \
+ $(LIBDRM_LIBS) \
+ $(CLOCK_LIB)
GLVND_GEN_DEPS = generate/gen_egl_dispatch.py \
generate/egl.xml generate/eglFunctionList.py generate/genCommon.py \