summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2016-10-26 10:14:37 -0700
committerEric Anholt <eric@anholt.net>2017-06-30 12:25:45 -0700
commit7f80a9ff1312406dcffae88bf6dcaaf99ca9e3a1 (patch)
treeb0de421d08cd0f3ee42f2a3e48c702f73772fefb /src/Makefile.am
parent6646f6ba0dca70478cafd39886005e387406f114 (diff)
vc4: Introduce XML-based packet header generation like Intel's.
I really liked this idea, as it should help with management of packet parsing tools like the CL dump. The python script is forked off of theirs because our packets are byte-based instead of dwords, and the changes to do so while avoiding performance regressions due to unaligned accesses were quite invasive. v2: Fix Android.mk paths, drop shebang for python script, fix overlap detection. Acked-by: Jason Ekstrand <jason@jlekstrand.net> Acked-by: Kenneth Graunke <kenneth@whitecape.org> Tested-by: Rob Herring <robh@kernel.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d8a2ee59fca..36995e08a45 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -82,6 +82,10 @@ if HAVE_INTEL_DRIVERS
SUBDIRS += intel
endif
+if HAVE_GALLIUM_VC4
+SUBDIRS += broadcom
+endif
+
if NEED_OPENGL_COMMON
SUBDIRS += mesa
endif