summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg Kristensen <krh@bitplanet.net>2016-08-19 12:13:24 -0700
committerKenneth Graunke <kenneth@whitecape.org>2016-08-23 21:19:33 -0700
commit3e218ad7f85e4f21d5d206adf7ebb283842f9732 (patch)
treef87f30a7c7a841454789da8f5ce71ed90ab9f526 /src/Makefile.am
parenteb1a0ddfd55ba606eb67fab2aaf337007acce904 (diff)
aubinator: Add a new tool called Aubinator to the src/intel/tools folder.
The Aubinator tool is designed to help the driver developers in debugging the driver functionality by decoding the data in the .aub files. Primary Authors of this tool are Damien Lespiau <damien.lespiau at intel.com> and Kristian Høgsberg Kristensen <krh at bitplanet.net>. v2: Review comments are incorporated by Sirisha Gandikota as below: 1) Make Makefile.am more crisp, reuse intel_aub.h from libdrm (per Emil) 2) Aubinator will use platform name instead of GEN number (per Matt) 3) Disassmebler gets created based on pciid rather then GEN number (per Matt) 4) Other formatting comments (per Ken, Matt and Emil) Signed-off-by: Sirisha Gandikota <Sirisha.Gandikota@intel.com> Acked-by: Kenneth Graunke <kenneth@whitecape.org> Acked-by: Ben Widawsky <ben@bwidawsk.net>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d4e34b47bee..cffb9e8b0a2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -83,6 +83,10 @@ if HAVE_EGL
SUBDIRS += egl
endif
+if HAVE_INTEL_DRIVERS
+SUBDIRS += intel/tools
+endif
+
## Requires the i965 compiler (part of mesa) and wayland-drm
if HAVE_INTEL_VULKAN
SUBDIRS += intel/vulkan