summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2016-04-29 18:41:08 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2016-05-01 08:38:04 +0100
commit3a2d09dd654fffb17a50699ac5fb293cb6be6e84 (patch)
tree39d89c55ff44ea14804399b789ecced05c2b2c40 /src/Makefile.am
parentfe918556a21fc6050a9e4905ef63452716a9a5ae (diff)
automake: include vulkan subdir after wayland-drm
We'll reuse the existing wayland-drm static library with next commit. Signed-off-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1471fa0e48a..9a1fddfacbc 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -32,11 +32,6 @@ if NEED_OPENGL_COMMON
SUBDIRS += mesa
endif
-# This explicitly comes after mesa because it depends on the i965 compiler
-if HAVE_INTEL_VULKAN
-SUBDIRS += intel/vulkan
-endif
-
SUBDIRS += loader
if HAVE_DRI_GLX
@@ -55,6 +50,11 @@ if HAVE_EGL
SUBDIRS += egl
endif
+## Requires the i965 compiler (part of mesa) and wayland-drm
+if HAVE_INTEL_VULKAN
+SUBDIRS += intel/vulkan
+endif
+
if HAVE_GALLIUM
SUBDIRS += gallium
endif