summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2015-03-24 09:41:08 -0700
committerKristian Høgsberg <kristian.h.kristensen@intel.com>2015-03-24 22:02:57 -0700
commit169b389a34966b921fe4b75baff5503c3a31a98a (patch)
treefedcfe9ae90449eaa20509a8975b6ec3a54e8879 /src/Makefile.am
parentbabd0fa3e28ae673128aaab55bd59fc3b7135be3 (diff)
mesa: Apply visibility flags to src/Makefile.am targets
We were building libglsl_util.la without our visibility flags and leaking hash_table_* symbols. Signed-off-by: Kristian Høgsberg <kristian.h.kristensen@intel.com> Reviewed-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8edf33373e9..874a3334a83 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -55,6 +55,9 @@ endif
EXTRA_DIST = egl/docs getopt hgl SConscript
+AM_CFLAGS = $(VISIBILITY_CFLAGS)
+AM_CXXFLAGS = $(VISIBILITY_CXXFLAGS)
+
AM_CPPFLAGS = \
-I$(top_srcdir)/include/ \
-I$(top_srcdir)/src/mapi/ \