summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAlejandro PiƱeiro <apinheiro@igalia.com>2019-11-25 16:29:12 +0100
committerMarge Bot <eric+marge@anholt.net>2020-10-13 21:21:24 +0000
commite5034f0d0d48ab541dad5d5e5c439fe82096950a (patch)
tree4c172db7339b83c0b9ea91fd773bcba250e70199 /meson.build
parentbdb1e5aa0ae6410ec829f6213549f951a5f17684 (diff)
v3dv: add v3d vulkan driver skeleton
Initial commit, mostly a import of the minimum from anv/radv to get a skeleton to start to work with. In includes: * meson files * Copy & adapt entrypoints ane extensions scripts from anv (that were later used on radv) This is a firt approach, but is is likely that we can remove/simplify some things. v2: fix copyright character at broadcom/vulkan/meson.build (Eric) v3: no spaces inside arrays (Dylan) v4: add gnu_symbol_visibility (detected by CI on first Merge attemp) Reviewed-by: Eric Anholt <eric@anholt.net> squash! v3dv: add v3d vulkan driver skeleton Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/6766>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 4eb6a982424..02a69c420c7 100644
--- a/meson.build
+++ b/meson.build
@@ -273,6 +273,7 @@ with_amd_vk = _vulkan_drivers.contains('amd')
with_freedreno_vk = _vulkan_drivers.contains('freedreno')
with_swrast_vk = _vulkan_drivers.contains('swrast')
with_freedreno_kgsl = get_option('freedreno-kgsl')
+with_broadcom_vk = _vulkan_drivers.contains('broadcom')
with_any_vk = _vulkan_drivers.length() != 0
if with_swrast_vk and not with_gallium_softpipe