summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2018-09-25 19:15:45 -0700
committerEric Anholt <eric@anholt.net>2019-07-25 08:56:19 -0700
commit82bf1979d7b7d83e8e213b11ff7787e6939c8f7e (patch)
tree595ad86905bae25e153d1c7a82041eedef0f20f7 /meson.build
parentc5f14322965cc006038e293902412e76ad268767 (diff)
v3d: Introduce a DRM shim for calling out to the simulator.
The goal is to enable testing of parts of drivers without depending on any particular kernel version or hardware being present. Simply set LD_PRELOAD=$PREFIX/lib/libv3d_drm_shim.so in your environment, and we'll fake a /dev/dri/renderD128 (or whatever the next available node is) using v3dv3. That node can then be used with the surfaceless or gbm EGL platforms. Acked-by: Iago Toral Quiroga <itoral@igalia.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 10 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 804b921b1a5..f4c013a5319 100644
--- a/meson.build
+++ b/meson.build
@@ -55,7 +55,16 @@ with_osmesa = get_option('osmesa')
with_swr_arches = get_option('swr-arches')
with_tools = get_option('tools')
if with_tools.contains('all')
- with_tools = ['etnaviv', 'freedreno', 'glsl', 'intel', 'nir', 'nouveau', 'xvmc']
+ with_tools = [
+ 'drm-shim',
+ 'etnaviv',
+ 'freedreno',
+ 'glsl',
+ 'intel',
+ 'nir',
+ 'nouveau',
+ 'xvmc',
+ ]
endif
dri_drivers_path = get_option('dri-drivers-path')