summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2020-02-18 16:03:19 -0800
committerMarge Bot <eric+marge@anholt.net>2020-02-25 21:45:06 +0000
commit11a1cb2fa8dadca9d918e8421a3b26a1b176937c (patch)
tree143e381f6e5f046cd279ba47e411421774470bef /meson.build
parent5dfd83d7a1ce52a42485c54ca170311449379eb9 (diff)
meson: Disable bison's -Wdeprecated since we still support old bison.
We can't stop using deprecated keywords because we maintain support for ancient bison. Silence the warning so that builds are less noisy. Acked-by: Timothy Arceri <tarceri@itsqueeze.com> Reviewed-by: Erik Faye-Lund <erik.faye-lund@collabora.com> Tested-by: Marge Bot <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/3868> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/3868>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 73ba1b24253..d69b17bb157 100644
--- a/meson.build
+++ b/meson.build
@@ -1508,6 +1508,12 @@ if host_machine.system() == 'windows'
endif
else
prog_bison = find_program('bison', required : with_any_opengl)
+
+ # Disable deprecated keyword warnings, since we have to use them for
+ # old-bison compat. See discussion in
+ # https://gitlab.freedesktop.org/mesa/mesa/merge_requests/2161
+ prog_bison = [prog_bison, '-Wno-deprecated']
+
prog_flex = find_program('flex', required : with_any_opengl)
endif