summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel Stone <daniels@collabora.com>2020-04-06 21:35:09 +0100
committerMarge Bot <eric+marge@anholt.net>2020-08-18 13:44:10 +0000
commit45f22528792d3ec072162aaff9b69a08bf1252e0 (patch)
tree342da117f942801ff43479adcd06e844a48986d5 /meson.build
parentd8edf8e383db716c4837c82cced1ae8d6f220551 (diff)
meson: Add MSVC narrowing-int-to-char warnings
MSVC seems quite keen to warn us that we're narrowing an int into a char, even if it fits entirely within range. Signed-off-by: Daniel Stone <daniels@collabora.com> Reviewed-by: Erik Faye-Lund <erik.faye-lund@collabora.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/6227>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 88dcc8151ea..f7ed6c73af6 100644
--- a/meson.build
+++ b/meson.build
@@ -984,6 +984,8 @@ if cc.get_id() == 'msvc'
'/wd4146', # unary minus operator applied to unsigned type, result still unsigned
'/wd4200', # nonstandard extension used: zero-sized array in struct/union
'/wd4624', # destructor was implicitly defined as deleted [from LLVM]
+ '/wd4309', # 'initializing': truncation of constant value
+ '/wd4838', # conversion from 'int' to 'const char' requires a narrowing conversion
]
if cc.has_argument(a)
c_args += a