summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-06-12 09:03:28 -0700
committerDylan Baker <dylan@pnwbakers.com>2018-06-13 10:07:03 -0700
commit9cc577761ff1165e0b99d3ceaa936b342dea10b1 (patch)
treea5d6971d490bdbc5cc8b69fe12c61c71a4a4957c /meson.build
parent0ce3f3538bd91d2568481f853a692b7711f9340d (diff)
meson: Remove various completed todos
v3: - Remove "won't do" todos, so only completed todo's are now removed. Signed-off-by: Dylan Baker <dylan.c.baker@intel.com> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Matt Turner <mattst88@gmail.com> (v2)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 0 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index bee526a4f22..aefb9f3c85e 100644
--- a/meson.build
+++ b/meson.build
@@ -1217,8 +1217,6 @@ if get_option('selinux')
pre_args += '-DMESA_SELINUX'
endif
-# TODO: llvm-prefix and llvm-shared-libs
-
if with_libunwind != 'false'
dep_unwind = dependency('libunwind', required : with_libunwind == 'true')
if dep_unwind.found()
@@ -1228,8 +1226,6 @@ else
dep_unwind = null_dep
endif
-# TODO: gallium-hud
-
if with_osmesa != 'none'
if with_osmesa == 'classic' and not with_dri_swrast
error('OSMesa classic requires dri (classic) swrast.')
@@ -1354,10 +1350,6 @@ else
dep_lmsensors = null_dep
endif
-# TODO: various libdirs
-
-# TODO: gallium driver dirs
-
foreach a : pre_args
add_project_arguments(a, language : ['c', 'cpp'])
endforeach