summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-04-24 14:15:47 -0700
committerDylan Baker <dylan@pnwbakers.com>2018-04-24 15:26:51 -0700
commit1d01b52d761227c9675b2785cc242ec51e803e84 (patch)
treebf6c578cb58cb6b84c4a1c667143915ed3097b9d /meson.build
parentbe0a2cfc65cbeceba5a74dc64e2200dc0fe01672 (diff)
meson: Fix no-rtti in llvm detection
Because I clearly wasn't thinking and clearly didn't do a good job testing. Sigh Fixes: c5a97d658ec19cc02719d7f86c1b0715e3d9ffc4 ("meson: fix builds against LLVM built without rtti") Signed-off-by: Dylan Baker <dylan.c.baker@intel.com> Reviewed-by: Marek Olšák <marek.olsak@amd.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 590ac40a781..52a1075823f 100644
--- a/meson.build
+++ b/meson.build
@@ -1149,7 +1149,7 @@ if with_llvm
# programs, so we need to build all C++ code in mesa without rtti as well to
# ensure that linking works.
if dep_llvm.get_configtool_variable('has-rtti') == 'NO'
- cpp_args('-fno-rtti')
+ cpp_args += '-fno-rtti'
endif
elif with_amd_vk or with_gallium_radeonsi or with_gallium_swr
error('The following drivers require LLVM: Radv, RadeonSI, SWR. One of these is enabled, but LLVM is disabled.')