summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChuck Atkins <chuck.atkins@kitware.com>2017-07-31 15:53:13 -0400
committerTim Rowley <timothy.o.rowley@intel.com>2017-08-03 11:06:50 -0500
commitf0da70a96432dff8f9ebf054b352ce9db45f3ad6 (patch)
tree8c3218e36b788630cd8a2d00f9276ab3ff33c85b /configure.ac
parent9966c85e01a4344d2a6bb76e432e0bed70d52ff6 (diff)
swr: Add arch flags to support Cray and PGI compilers
Note that the Cray flags (-target-cpu=) need to come first since the cray programming environment uses wappers around other compilers. By checking the wrapper flags first, you can be sure to match the wrapper flag instead of the underlying compiler (gcc, intel, pgi, etc.) flags. Signed-off-by: Chuck Atkins <chuck.atkins@kitware.com> Reviewed-by: Tim Rowley <timothy.o.rowley@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6302aa2b0c8..3b45baf6d08 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2511,7 +2511,7 @@ if test -n "$with_gallium_drivers"; then
AC_SUBST([SWR_CXX11_CXXFLAGS])
swr_require_cxx_feature_flags "AVX" "defined(__AVX__)" \
- ",-mavx,-march=core-avx" \
+ ",-target-cpu=sandybridge,-mavx,-march=core-avx,-tp=sandybridge" \
SWR_AVX_CXXFLAGS
AC_SUBST([SWR_AVX_CXXFLAGS])
@@ -2523,21 +2523,21 @@ if test -n "$with_gallium_drivers"; then
;;
xavx2)
swr_require_cxx_feature_flags "AVX2" "defined(__AVX2__)" \
- ",-mavx2 -mfma -mbmi2 -mf16c,-march=core-avx2" \
+ ",-target-cpu=haswell,-mavx2 -mfma -mbmi2 -mf16c,-march=core-avx2,-tp=haswell" \
SWR_AVX2_CXXFLAGS
AC_SUBST([SWR_AVX2_CXXFLAGS])
HAVE_SWR_AVX2=yes
;;
xknl)
swr_require_cxx_feature_flags "KNL" "defined(__AVX512F__) && defined(__AVX512ER__)" \
- ",-march=knl,-xMIC-AVX512" \
+ ",-target-cpu=mic-knl,-march=knl,-xMIC-AVX512" \
SWR_KNL_CXXFLAGS
AC_SUBST([SWR_KNL_CXXFLAGS])
HAVE_SWR_KNL=yes
;;
xskx)
swr_require_cxx_feature_flags "SKX" "defined(__AVX512F__) && defined(__AVX512BW__)" \
- ",-march=skylake-avx512,-xCORE-AVX512" \
+ ",-target-cpu=x86-skylake,-march=skylake-avx512,-xCORE-AVX512" \
SWR_SKX_CXXFLAGS
AC_SUBST([SWR_SKX_CXXFLAGS])
HAVE_SWR_SKX=yes