summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2017-05-03 21:24:26 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2017-05-19 19:44:04 +0100
commitedb5a65f93189472814afa97b1e3a54b2478b543 (patch)
treecf318e464fdf061eaa4ac77f75e6ef6bbb591f40 /configure.ac
parent73682f82bc8ab2b96b76ec12da9d2d130ec5e352 (diff)
configure: loosen --with-platforms heuristics
Remove the enable-egl pre-requirement. Platform selection does not depend on EGL. Cc: <mesa-stable@lists.freedesktop.org> Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Eric Engestrom <eric@engestrom.ch>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 2c930004cfb..de422107a26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1643,14 +1643,10 @@ AC_ARG_WITH([egl-platforms],
[with_egl_platforms=auto])
if test "x$with_egl_platforms" = xauto; then
- if test "x$enable_egl" = xyes; then
- if test "x$enable_gbm" = xyes; then
- with_egl_platforms="x11,drm"
- else
- with_egl_platforms="x11"
- fi
+ if test "x$enable_gbm" = xyes; then
+ with_egl_platforms="x11,drm"
else
- with_egl_platforms=""
+ with_egl_platforms="x11"
fi
else
AC_MSG_WARN([--with-egl-platforms is deprecated. Use --with-platforms instead.])