summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2011-07-14 23:07:19 +0100
committerMarek Olšák <maraeo@gmail.com>2011-07-19 03:13:35 +0200
commitc2426bbf862850504f24e7d9765e64a75b873f3b (patch)
tree6ea115d0a258c30f28389729f54f8b3fe5d50e64 /configure.ac
parent8c47a5da9fd30ab44705cd1075fe7730da5aa0f9 (diff)
configure.ac: Check for the respective libdrm_* when building gallium drivers
In a rare case of building gallium only, we need to check if the required packages are available libdrm_[intel|nouveau] - gallium[i915 i965|nouveau] v2: r300g and r600g do not need libdrm_radeon Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Signed-off-by: Marek Olšák <maraeo@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5c76c286519..f72db119fb3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1906,6 +1906,7 @@ if test "x$with_gallium_drivers" != x; then
gallium_check_st "svga/drm" "dri-vmwgfx" "xorg-vmwgfx" "xa-vmwgfx"
;;
xi915)
+ PKG_CHECK_MODULES([INTEL], [libdrm_intel >= $LIBDRM_INTEL_REQUIRED])
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS i915 softpipe"
if test "x$MESA_LLVM" = x1; then
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS llvmpipe"
@@ -1914,6 +1915,7 @@ if test "x$with_gallium_drivers" != x; then
gallium_check_st "i915/drm" "dri-i915" "xorg-i915"
;;
xi965)
+ PKG_CHECK_MODULES([INTEL], [libdrm_intel >= $LIBDRM_INTEL_REQUIRED])
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS i965 softpipe"
if test "x$MESA_LLVM" = x1; then
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS llvmpipe"
@@ -1930,6 +1932,7 @@ if test "x$with_gallium_drivers" != x; then
gallium_check_st "r600/drm" "dri-r600" "" "" "xvmc-r600" "vdpau-r600" "va-r600"
;;
xnouveau)
+ PKG_CHECK_MODULES([NOUVEAU], [libdrm_nouveau >= $LIBDRM_NOUVEAU_REQUIRED])
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS nouveau nvfx nv50 nvc0"
gallium_check_st "nouveau/drm" "dri-nouveau" "xorg-nouveau" "" "xvmc-nouveau"
;;