summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2012-01-11 18:32:14 -0500
committerMatt Turner <mattst88@gmail.com>2012-01-20 14:56:42 -0500
commitadefee50d954151f76150af80207081ae3c247d9 (patch)
treec70cf0abe077c38d76a22eef437673a6692dd2bf /configure.ac
parent2fdbbeca43e7b57095774e4228e6eea75a180fab (diff)
Always build shared glapi
libglapi.so, libGL.so, libGLESv2.so, libGLESv1_CM.so must all come from the same version of Mesa or bad things may happen. Acked-by: Kenneth Graunke <kenneth@whitecape.org> Signed-off-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 1 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index e13c4cfc57f..f8e69b7ced2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -711,18 +711,6 @@ if test "x$enable_gles2" = xyes; then
fi
AC_SUBST([API_DEFINES])
-AC_ARG_ENABLE([shared-glapi],
- [AS_HELP_STRING([--enable-shared-glapi],
- [EXPERIMENTAL. Enable shared glapi for OpenGL @<:@default=no@:>@])],
- [enable_shared_glapi="$enableval"],
- [enable_shared_glapi=no])
-
-SHARED_GLAPI="0"
-if test "x$enable_shared_glapi" = xyes; then
- SHARED_GLAPI="1"
-fi
-AC_SUBST([SHARED_GLAPI])
-
dnl
dnl Driver configuration. Options are xlib, dri and osmesa right now.
dnl More later: fbdev, ...
@@ -806,7 +794,7 @@ dnl Driver specific build directories
dnl
dnl this variable will be prepended to SRC_DIRS and is not exported
-CORE_DIRS=""
+CORE_DIRS="mapi/shared-glapi"
SRC_DIRS=""
GLU_DIRS="sgi"
@@ -816,13 +804,6 @@ GALLIUM_WINSYS_DIRS="sw"
GALLIUM_DRIVERS_DIRS="galahad trace rbug noop identity"
GALLIUM_STATE_TRACKERS_DIRS=""
-# build shared-glapi if enabled for OpenGL or if OpenGL ES is enabled
-case "x$enable_shared_glapi$enable_gles1$enable_gles2" in
-x*yes*)
- CORE_DIRS="$CORE_DIRS mapi/shared-glapi"
- ;;
-esac
-
# build glapi if OpenGL is enabled
if test "x$enable_opengl" = xyes; then
CORE_DIRS="$CORE_DIRS mapi/glapi"
@@ -1377,9 +1358,6 @@ if test "x$enable_gbm" = xyes; then
if test "x$enable_dri" = xyes; then
GBM_BACKEND_DIRS="$GBM_BACKEND_DIRS dri"
- if test "$SHARED_GLAPI" -eq 0; then
- AC_MSG_ERROR([gbm_dri requires --enable-shared-glapi])
- fi
fi
fi
AC_SUBST([GBM_LIB_DEPS])