summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olv@lunarg.com>2010-05-05 10:59:44 +0800
committerChia-I Wu <olv@lunarg.com>2010-05-05 11:57:46 +0800
commita6ec153830ea25958f8cb5f5b5ae7a3433d61bbc (patch)
treed7a97f7581cb6e9c5232c1a17ff1452eb4614dbb /configure.ac
parentb29b27c118f2f813b07475e0c470b338ed5987aa (diff)
mesa: Fix build of ES overlay.
ES overlay is built with FEATURE_ES1 or FEATURE_ES2, and is built without FEATURE_GL. Fix the build by always building OpenGL ES sources, but test for FEATURE_ES1 or FEATURE_ES2. Also, define symbols that are missing because FEATURE_GL is not defined.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 5a0ee136b59..b2e49a71365 100644
--- a/configure.ac
+++ b/configure.ac
@@ -748,8 +748,6 @@ AC_ARG_ENABLE([gles2],
API_DEFINES=""
APIS=""
-ES1_SOURCES=""
-ES2_SOURCES=""
if test "x$enable_opengl" = xno; then
API_DEFINES="$API_DEFINES -DFEATURE_GL=0"
else
@@ -759,20 +757,16 @@ fi
if test "x$enable_gles1" = xyes; then
API_DEFINES="$API_DEFINES -DFEATURE_ES1=1"
APIS="$APIS es1"
- ES1_SOURCES='$(ES1_SOURCES)'
fi
if test "x$enable_gles2" = xyes; then
API_DEFINES="$API_DEFINES -DFEATURE_ES2=1"
APIS="$APIS es2"
- ES2_SOURCES='$(ES2_SOURCES)'
fi
if test "x$enable_gles1" = xyes -o "x$enable_gles2" = xyes; then
SRC_DIRS="$SRC_DIRS gles"
fi
AC_SUBST([API_DEFINES])
AC_SUBST([APIS])
-AC_SUBST([ES1_SOURCES])
-AC_SUBST([ES2_SOURCES])
dnl If $with_dri_drivers is yes, directories will be added through
dnl platform checks