summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2013-01-14 14:38:01 -0800
committerMatt Turner <mattst88@gmail.com>2013-01-16 13:31:36 -0800
commit99629735e79084597a4255c2a9bf9fab38d73007 (patch)
treee87c5736865e28d97b0d2fb24281a4358fdaf6e5 /configure.ac
parente6e73089e5d78094dd5b36e37c824cc42f54c8c4 (diff)
build: Make src/gtest before src/mesa
Fixes a make check problem where libgtest.la wasn't build before tests that want to link with it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2d74b825da3..99a08fd060f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -739,7 +739,6 @@ AM_CONDITIONAL(HAVE_SHARED_GLAPI, test "x$enable_shared_glapi" = xyes)
dnl
dnl Driver specific build directories
dnl
-SRC_DIRS="gtest"
GALLIUM_DIRS="auxiliary drivers state_trackers"
GALLIUM_TARGET_DIRS=""
GALLIUM_WINSYS_DIRS="sw"
@@ -764,7 +763,7 @@ fi
# build glsl and mesa if OpenGL or OpenGL ES is enabled
case "x$enable_opengl$enable_gles1$enable_gles2" in
x*yes*)
- CORE_DIRS="mapi/glapi/gen $CORE_DIRS glsl mesa"
+ CORE_DIRS="mapi/glapi/gen $CORE_DIRS gtest glsl mesa"
;;
esac