summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2010-02-25 16:12:58 -0500
committerKristian Høgsberg <krh@bitplanet.net>2010-02-25 17:40:11 -0500
commit79aeafd3ca3680c28f6d47a21a501334844f4475 (patch)
tree211ec598f55db38cdf62133ab56dd82cb8fd24a6 /configure.ac
parent40c6bb58be4bc2be3c4901fe8b945d2a12983af6 (diff)
Drop fb, ffb and gamma dri drivers
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 5 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index b4561000d22..d108ecdad29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -720,10 +720,9 @@ if test "$mesa_driver" = dri; then
case "$host_cpu" in
x86_64)
- # ffb, gamma, and sis are missing because they have not be
- # converted to use the new interface. i810 are missing
- # because there is no x86-64 system where they could *ever*
- # be used.
+ # sis is missing because they have not be converted to use
+ # the new interface. i810 are missing because there is no
+ # x86-64 system where they could *ever* be used.
if test "x$DRI_DIRS" = "xyes"; then
DRI_DIRS="i915 i965 mach64 mga r128 r200 r300 r600 radeon \
savage tdfx unichrome swrast"
@@ -739,7 +738,7 @@ if test "$mesa_driver" = dri; then
sparc*)
# Build only the drivers for cards that exist on sparc`
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="mach64 r128 r200 r300 r600 radeon ffb swrast"
+ DRI_DIRS="mach64 r128 r200 r300 r600 radeon swrast"
fi
;;
esac
@@ -755,8 +754,6 @@ if test "$mesa_driver" = dri; then
CXXFLAGS="$CXXFLAGS -ansi -pedantic"
fi
- # ffb and gamma are missing because they have not been converted
- # to use the new interface.
if test "x$DRI_DIRS" = "xyes"; then
DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon tdfx \
unichrome savage sis swrast"
@@ -778,7 +775,7 @@ if test "$mesa_driver" = dri; then
# default drivers
if test "x$DRI_DIRS" = "xyes"; then
DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon \
- savage sis tdfx unichrome ffb swrast"
+ savage sis tdfx unichrome swrast"
fi
DRI_DIRS=`echo "$DRI_DIRS" | $SED 's/ */ /g'`