summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-01-21 19:44:45 +0000
committerEric Engestrom <eric.engestrom@intel.com>2019-01-22 16:12:40 +0000
commit610f956fdead37da49ee2857a2261c3dfd8fc3cd (patch)
tree3678ed6539386f9a900c4b16bac27c40c0de5b49 /configure.ac
parentfc4f6b2f12bd6b7b2b2b727f84563bf1fec308b8 (diff)
configure: EGL requirements only apply if EGL is built
Issue was hit with this configuration: --disable-{egl,gbm} --with-platform=drm Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Fixes: 3208fd2e46b ("configure: move platform handling further up") Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c7473d77eff..7530f65ad4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1877,6 +1877,7 @@ for plat in $platforms; do
;;
drm)
+ test "x$enable_egl" = "xyes" &&
test "x$enable_gbm" = "xno" &&
AC_MSG_ERROR([EGL platform drm needs gbm])
DEFINES="$DEFINES -DHAVE_DRM_PLATFORM"