summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2008-03-20 17:14:20 -0700
committerEric Anholt <eric@anholt.net>2008-03-21 14:19:29 -0700
commit5ad06156b2ed3b157445d3569888bb5f5091791e (patch)
tree36ca4701c5269aa4ebba127e5a15db0f4b38f76f /configure.ac
parentd933be6baf98624c609d422a9b083a08f67e8bdb (diff)
Fix autoconf build on FreeBSD: detect gmake, and put -D*_SOURCE under linux.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b9ad819fe43..504d9acdc91 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,7 +26,10 @@ dnl Check for progs
AC_PROG_CPP
AC_PROG_CC
AC_PROG_CXX
-AC_PATH_PROG(MAKE, make)
+AC_PATH_PROG(MAKE, gmake, [not_found])
+if test "x$MAKE" = "xnot_found"; then
+ AC_PATH_PROG(MAKE, make)
+fi
AC_PATH_PROG(MKDEP, makedepend)
AC_PATH_PROG(SED, sed)
@@ -64,11 +67,11 @@ AC_SUBST(X11_INCLUDES)
dnl Compiler macros
DEFINES=""
AC_SUBST(DEFINES)
-if test "x$GCC" = xyes; then
- DEFINES="-D_POSIX_SOURCE -D_POSIX_C_SOURCE=199309L -D_BSD_SOURCE"
-fi
case "$host_os" in
linux*)
+if test "x$GCC" = xyes; then
+ DEFINES="$DEFINES -D_POSIX_SOURCE -D_POSIX_C_SOURCE=199309L -D_BSD_SOURCE"
+fi
DEFINES="$DEFINES -D_SVID_SOURCE -D_GNU_SOURCE -DPTHREADS -DHAVE_POSIX_MEMALIGN"
;;
esac