summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Heidelberg <david@ixit.cz>2015-04-11 00:13:53 +0200
committerAxel Davy <axel.davy@ens.fr>2015-08-21 22:21:45 +0200
commit56717c0b069a20b0c4438ac1dc9280cd9026b36f (patch)
tree14c3659fb545f30e7f25d45da3b47147c80a9fb9 /configure.ac
parent365d631eb220e7d546a726d6f38f76e2e3746d65 (diff)
st/nine: Require gcc >= 4.6
Nine code uses some C11 features, and this leads to compile error on gcc <= 4.5 Another way would have been to use the -fms-extensions CFLAG Signed-off-by: David Heidelberg <david@ixit.cz> Cc: "10.4 10.5 10.6" <mesa-stable@lists.freedesktop.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1c4e4c24483..e3b5f2e3124 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1633,6 +1633,10 @@ if test "x$enable_nine" = xyes; then
if test "x$with_gallium_drivers" = xswrast; then
AC_MSG_ERROR([nine requires at least one non-swrast gallium driver])
fi
+ if test $GCC_VERSION_MAJOR -lt 4 -o $GCC_VERSION_MAJOR -eq 4 -a $GCC_VERSION_MINOR -lt 6; then
+ AC_MSG_ERROR([gcc >= 4.6 is required to build nine])
+ fi
+
if test "x$enable_dri3" = xno; then
AC_MSG_WARN([using nine together with wine requires DRI3 enabled system])
fi