summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian Paul <brianp@vmware.com>2009-08-14 11:23:00 -0600
committerBrian Paul <brianp@vmware.com>2009-08-14 11:23:00 -0600
commit467b3d9a6f32b38c36a4be145b07c8f7b719215a (patch)
tree0ac427670cb7d02e2267ff043c3a5aeb80864bca /configure.ac
parente691b0e533c552dc5884192a9a2b9347f704479d (diff)
Add configure options for MAX_WIDTH/HEIGHT.
This adds two --with configure options for setting defines for MAX_WIDTH and MAX_HEIGHT. It's conceivably just as easy to define these in CFLAGS manually, but this way users don't need to know about internal Mesa details. Patch updated by BrianP to set DEFINES, not CFLAGS. (cherry picked from master, commit 7085dce750f478312a47f474330d63cc900a8448)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f1ff3d4f472..8607ff17a3c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1145,6 +1145,21 @@ AC_ARG_WITH([xorg-driver-dir],
[XORG_DRIVER_INSTALL_DIR="${libdir}/xorg/modules/drivers"])
AC_SUBST([XORG_DRIVER_INSTALL_DIR])
+AC_ARG_WITH([max-width],
+ [AS_HELP_STRING([--with-max-width=N],
+ [Maximum framebuffer width (4096)])],
+ [DEFINES="${DEFINES} -DMAX_WIDTH=${withval}";
+ AS_IF([test "${withval}" -gt "4096"],
+ [AC_MSG_WARN([Large framebuffer: see s_tritemp.h comments.])])]
+)
+AC_ARG_WITH([max-height],
+ [AS_HELP_STRING([--with-max-height=N],
+ [Maximum framebuffer height (4096)])],
+ [DEFINES="${DEFINES} -DMAX_HEIGHT=${withval}";
+ AS_IF([test "${withval}" -gt "4096"],
+ [AC_MSG_WARN([Large framebuffer: see s_tritemp.h comments.])])]
+)
+
dnl
dnl Gallium Intel configuration
dnl