summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorQuentin Glidic <sardemff7+git@sardemff7.net>2013-01-25 15:02:04 +0100
committerTom Stellard <thomas.stellard@amd.com>2013-02-01 22:53:46 +0000
commit1e857130f06d7db0c77d73b6356528f4792967ff (patch)
treeecdaa1bd8c99e52a60df9c1f4d337f6da84d51af /configure.ac
parent257006e2a4201c11ca5f800a74ac4aaf62a7bfc1 (diff)
configure.ac: Fix --with-llvm-shared-libs
The third argument of AC_ARG_WITH is evaluated for any provided value, not only on --with-, so it must not force-enable the feature Also, setting $with_llvm_shared_libs in the opencl check was overriding the user switch https://bugs.freedesktop.org/show_bug.cgi?id=59851 Signed-off-by: Quentin Glidic <sardemff7+git@sardemff7.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 95c9f3dbe9b..abfe3d7bd63 100644
--- a/configure.ac
+++ b/configure.ac
@@ -611,7 +611,7 @@ AC_ARG_ENABLE([opencl],
[enable OpenCL library NOTE: Enabling this option will also enable
--with-llvm-shared-libs
@<:@default=no@:>@])],
- [enable_opencl="$enableval" with_llvm_shared_libs="$enableval"],
+ [],
[enable_opencl=no])
AC_ARG_ENABLE([xlib_glx],
[AS_HELP_STRING([--enable-xlib-glx],
@@ -1629,8 +1629,13 @@ AC_ARG_ENABLE([gallium-llvm],
AC_ARG_WITH([llvm-shared-libs],
[AS_HELP_STRING([--with-llvm-shared-libs],
[link with LLVM shared libraries @<:@default=disabled@:>@])],
- [with_llvm_shared_libs=yes],
+ [],
[with_llvm_shared_libs=no])
+AS_IF([test x$enable_opencl = xyes],
+ [
+ AC_MSG_WARN([OpenCL required, forcing LLVM shared libraries])
+ with_llvm_shared_libs=yes
+ ])
AC_ARG_WITH([llvm-prefix],
[AS_HELP_STRING([--with-llvm-prefix],