summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2016-12-05 20:14:24 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2017-05-19 19:44:25 +0100
commit05043e0e8e0bd5e3019f480557d452b4c165f8f2 (patch)
tree678b20bf7e9a4abb9328b37a55960842ecd62f27 /configure.ac
parentd80d6d662e4199e9a4ec9d924007f8fb0b91b444 (diff)
configure: error out when building X11 Vulkan without DRI3
Vulkan supports only DRI3 enabled X11 platforms. Make it obvious, should one consider building without it. Cc: Jason Ekstrand <jason@jlekstrand.net> Cc: Ville Syrjälä <ville.syrjala@linux.intel.com> Cc: mesa-stable@lists.freedesktop.org Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Eric Engestrom <eric@engestrom.ch>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 14f0c6e3c80..cd66101c3da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1930,6 +1930,14 @@ AC_ARG_WITH([vulkan-icddir],
[VULKAN_ICD_INSTALL_DIR='${datarootdir}/vulkan/icd.d'])
AC_SUBST([VULKAN_ICD_INSTALL_DIR])
+require_x11_dri3() {
+ if echo "$platforms" | grep -q 'x11'; then
+ if test "x$enable_dri3" != xyes; then
+ AC_MSG_ERROR([$1 Vulkan driver requires DRI3 when built with X11])
+ fi
+ fi
+}
+
if test -n "$with_vulkan_drivers"; then
if test "x$ac_cv_func_dl_iterate_phdr" = xno; then
AC_MSG_ERROR([Vulkan drivers require the dl_iterate_phdr function])
@@ -1941,12 +1949,14 @@ if test -n "$with_vulkan_drivers"; then
xintel)
require_libdrm "ANV"
PKG_CHECK_MODULES([INTEL], [libdrm >= $LIBDRM_INTEL_REQUIRED libdrm_intel >= $LIBDRM_INTEL_REQUIRED])
+ require_x11_dri3 "ANV"
HAVE_INTEL_VULKAN=yes
;;
xradeon)
require_libdrm "radv"
PKG_CHECK_MODULES([AMDGPU], [libdrm >= $LIBDRM_AMDGPU_REQUIRED libdrm_amdgpu >= $LIBDRM_AMDGPU_REQUIRED])
radeon_llvm_check $LLVM_REQUIRED_RADV "radv"
+ require_x11_dri3 "radv"
HAVE_RADEON_VULKAN=yes
;;
*)