summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2015-08-11 15:21:03 -0700
committerMatt Turner <mattst88@gmail.com>2015-08-11 15:21:03 -0700
commit02a4fe22b137d4bc8378bedd8319109fd23a50e3 (patch)
tree105c7c1c22bf3cf062399ef6bc1062e06e1a855e /configure.ac
parent2265321834608c26b2989a5a1f65bb375826a779 (diff)
configure.ac: Always define __STDC_LIMIT_MACROS.
... which ensures that we get defines like LONG_MAX in C++. Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=91591 Reviewed-by: Jose Fonseca <jfonseca@vmware.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 36197d3396a..4e751e36829 100644
--- a/configure.ac
+++ b/configure.ac
@@ -235,7 +235,7 @@ _SAVE_LDFLAGS="$LDFLAGS"
_SAVE_CPPFLAGS="$CPPFLAGS"
dnl Compiler macros
-DEFINES=""
+DEFINES="-D__STDC_LIMIT_MACROS"
AC_SUBST([DEFINES])
case "$host_os" in
linux*|*-gnu*|gnu*)