summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2012-09-18 16:15:15 +0200
committerMichael Stahl <mstahl@redhat.com>2012-09-18 18:18:23 +0200
commit970b56c40c0c66125d4dfe6d7708c3535551cd4a (patch)
tree90093032878a80c964755d20a334ad42b459e871 /configure.in
parent78051aaa688cc330a0cc053eecc7eef24a195c49 (diff)
mark configure's warning with some color
Change-Id: I7e225fc5ce353316cb689dc3bca8f606273e8796
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 28f7fb021fca..eafb07b217df 100644
--- a/configure.in
+++ b/configure.in
@@ -56,8 +56,14 @@ add_warning()
if test "$have_WARNINGS" = "no" ; then
echo "*************************************" >> warn
have_WARNINGS="yes"
+ if test $(tput colors) -ge 8 ; then
+ dnl <esc> as actual byte (U+1b), [ escaped using quadrigraph @<:@
+ COLORWARN='*@<:@1;33;40m WARNING @<:@0m:'
+ else
+ COLORWARN="* WARNING :"
+ fi
fi
- echo "* WARNING : $@" >> warn
+ echo "$COLORWARN $@" >> warn
}
if test -n "$SOLARENV" ; then