summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2012-09-18 15:22:59 +0200
committerMichael Stahl <mstahl@redhat.com>2012-09-18 18:18:23 +0200
commit78051aaa688cc330a0cc053eecc7eef24a195c49 (patch)
tree3d852bc31886f3409a70f86d77d3b1f6b2b49214 /configure.in
parent85dbc8129887fb94370afcb587e2a9264cb2ed10 (diff)
be consistent with configure's default and switch wrt gtk3
also record the system-cairo stuff as a proper warning, so that people have a chance to see it. Change-Id: Ic59bed91edbe92a642851ccef570c9dca94672f0
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index f8a4a4524049..28f7fb021fca 100644
--- a/configure.in
+++ b/configure.in
@@ -812,7 +812,7 @@ AC_ARG_ENABLE(gtk,
,enable_gtk=yes)
AC_ARG_ENABLE(gtk3,
- AS_HELP_STRING([--disable-gtk3],
+ AS_HELP_STRING([--enable-gtk3],
[Determines whether to use Gtk+ 3.0 vclplug on platforms where Gtk+ 3.0 is available.]),
,enable_gtk3=no)
@@ -9195,7 +9195,8 @@ GTK3_LIBS=""
ENABLE_GTK3=""
if test "x$enable_gtk3" = "xyes"; then
if test "$with_system_cairo" != yes; then
- echo "System cairo required for gtk3 support, please use --with-system-cairo"
+ AC_MSG_WARN([System cairo required for gtk3 support, please use --with-system-cairo])
+ add_warning "System cairo required for gtk3 support, please use --with-system-cairo"
fi
PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.2 gtk+-unix-print-3.0 gmodule-no-export-2.0 cairo, ENABLE_GTK3="TRUE", ENABLE_GTK3="")
if test "x$ENABLE_GTK3" = "xTRUE"; then