summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2017-03-02 17:48:57 +0100
committerStephan Bergmann <sbergman@redhat.com>2017-03-02 18:58:56 +0000
commitf4884d051f1eea07a0fe371834cb7c1da1cbee07 (patch)
treef8552a97da11e8987b4f11c269928a9cde385148 /configure.ac
parentb167466147baec95a3b123a07d648fc2589bc3c9 (diff)
Remove HAVE_CXX11_UTF16_STRING_LITERAL, always true now
...after 84b36c704d73362d4d86dc9e9c0efa0625958347 "Drop support for MSVC 2013". Make this a fatal configuration error for now. The check should be removed completely after LO 5.4 branch-off. Change-Id: If2f196abb93607dde9ba5c4f04d219679585e633 Reviewed-on: https://gerrit.libreoffice.org/34822 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c56e6f3652dc..9b4f7422891e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6309,8 +6309,8 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
AC_LANG_POP([C++])
CXXFLAGS=$save_CXXFLAGS
AC_MSG_RESULT([$cxx11_utf16_string_literal])
-if test "$cxx11_utf16_string_literal" = yes; then
- AC_DEFINE([HAVE_CXX11_UTF16_STRING_LITERAL])
+if test "$cxx11_utf16_string_literal" = no; then
+ AC_MSG_ERROR([Your $CXX does not support UTF-16 string literals. This is no longer supported.])
fi
dnl _Pragma support (may require C++11)