summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2017-03-02 17:43:25 +0100
committerStephan Bergmann <sbergman@redhat.com>2017-03-02 18:58:40 +0000
commitb167466147baec95a3b123a07d648fc2589bc3c9 (patch)
treea203d24b236c49f7ea6538e6613df19b7d4b81ed /configure.ac
parent51c0054a6fb956ff758206b4113ae2e76f82f5d4 (diff)
Remove HAVE_CXX11_CONSTEXPR, always true now
...after 84b36c704d73362d4d86dc9e9c0efa0625958347 "Drop support for MSVC 2013". Make this a fatal configuration error for now. The check should be removed completely after LO 5.4 branch-off. Change-Id: I990fd8fcb4ec1327282df4efe21640c938d3cf06 Reviewed-on: https://gerrit.libreoffice.org/34821 Reviewed-by: Stephan Bergmann <sbergman@redhat.com> Tested-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a4f0503aa3e1..c56e6f3652dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6244,8 +6244,8 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
AC_LANG_POP([C++])
CXXFLAGS=$save_CXXFLAGS
AC_MSG_RESULT([$cxx11_constexpr])
-if test "$cxx11_constexpr" = yes; then
- AC_DEFINE([HAVE_CXX11_CONSTEXPR])
+if test "$cxx11_constexpr" = no; then
+ AC_MSG_ERROR([Your $CXX does not support 'constexpr'. This is no longer supported.])
fi
AC_MSG_CHECKING([whether $CXX supports C++14 constexpr])