summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-12-07 12:24:05 +0100
committerStephan Bergmann <sbergman@redhat.com>2018-12-07 22:47:49 +0100
commit66ef8ca217680095d8aaae025d82c2cbcd8ec1d2 (patch)
tree2a7f4d2b5892c5fea9b89f0f27ccd6f771af5769 /configure.ac
parent7ffdd830d5fb52f2ca25aa80277d22ea6d89970b (diff)
HAVE_CPP_INLINE_VARIABLES is always true now
...but for safety, leave the configure.ac check in for some longer. Also remove now-redundant SAL_INLINE_VARIABLE again (which was LIBO_INTERNAL_ONLY). Change-Id: Id049e0cb84b4f97f5859f1b16b867b39b448dec0 Reviewed-on: https://gerrit.libreoffice.org/64772 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 0055641ae95f..b7b3b03b90cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12474,7 +12474,8 @@ if test "$build_os" = "cygwin"; then
AC_SUBST(ILIB)
fi
-AC_MSG_CHECKING([whether $CXX supports inline variables])
+dnl This check can eventually be removed completely (e.g., after libreoffice-6-3 branch off):
+AC_MSG_CHECKING([that $CXX supports inline variables])
AC_LANG_PUSH([C++])
save_CXXFLAGS=$CXXFLAGS
CXXFLAGS="$CXXFLAGS $CXXFLAGS_CXX11"
@@ -12490,10 +12491,8 @@ AC_LINK_IFELSE([AC_LANG_PROGRAM([[
struct T { static constexpr S s{}; };
S const * f() { return &T::s; }
#endif
- ]])], [
- AC_DEFINE([HAVE_CPP_INLINE_VARIABLES],[1])
- AC_MSG_RESULT([yes])
- ], [AC_MSG_RESULT([no])])
+ ]])],
+ AC_MSG_RESULT([yes]), AC_MSG_ERROR([$CXX lacks required inline variable support]))
CXXFLAGS=$save_CXXFLAGS
if test "$build_os" = cygwin; then
LIB=$save_LIB