summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-12-07 11:57:21 +0100
committerStephan Bergmann <sbergman@redhat.com>2018-12-07 22:47:08 +0100
commit7ffdd830d5fb52f2ca25aa80277d22ea6d89970b (patch)
tree0ccd68b656c6e37169730b33249e4a4a2ff46314 /configure.ac
parent7d928d8c6eb03c4e5e0d1961e9b62718ab53fb46 (diff)
HAVE_CPP_ATTRIBUTE_FALLTHROUGH is always true now
...but for safety, leave the configure.ac check in for some longer. Also, save removing now-redundant SAL_FALLTHROUGH for a follow-up commit. Change-Id: I9bf42d237aea4c09459f28275568cf340e588607 Reviewed-on: https://gerrit.libreoffice.org/64770 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 3d25986d1fae..0055641ae95f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6413,7 +6413,8 @@ if test "$GCC" = yes; then
fi
AC_SUBST([HAVE_GCC_FNO_SIZED_DEALLOCATION])
-AC_MSG_CHECKING([[whether $CXX supports [[fallthrough]]]])
+dnl This check can eventually be removed completely (e.g., after libreoffice-6-3 branch off):
+AC_MSG_CHECKING([[that $CXX supports [[fallthrough]]]])
AC_LANG_PUSH([C++])
save_CXXFLAGS=$CXXFLAGS
CXXFLAGS="$CXXFLAGS $CXXFLAGS_CXX11"
@@ -6441,10 +6442,8 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
}
}
#endif
- ]])], [
- AC_DEFINE([HAVE_CPP_ATTRIBUTE_FALLTHROUGH],[1])
- AC_MSG_RESULT([yes])
- ], [AC_MSG_RESULT([no])])
+ ]])],
+ AC_MSG_RESULT([yes]), AC_MSG_ERROR([$CXX lacks required [[fallthrough]] support]))
CXXFLAGS=$save_CXXFLAGS
AC_LANG_POP([C++])