summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Gundersen <teg@jklm.no>2013-01-05 18:37:52 +0100
committerTom Gundersen <teg@jklm.no>2013-01-07 15:15:57 +0100
commitd562955eac58d3a5089e0f344ea586412a134451 (patch)
tree4fca28daee0e2216e50f0d4fa48483f6df0a99d8 /configure.ac
parentcbc06dcd8f74e9e757c55884a4acf49784fc3444 (diff)
nss-myhostname: integrate into systemd buildsystem
Note that there are still some rome for cleanups. In particular, the .la files are now installed, which we probably don't want; and some of the macros in Makefile.am are likely redundan.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a8d48871d..b9499dc69 100644
--- a/configure.ac
+++ b/configure.ac
@@ -653,6 +653,25 @@ AC_SUBST(KBD_LOADKEYS)
AC_SUBST(KBD_SETFONT)
# ------------------------------------------------------------------------------
+have_myhostname=no
+AC_ARG_ENABLE(myhostname, AS_HELP_STRING([--disable-nss-myhostname], [disable nss-myhostname support]))
+if test "x$enable_myhostname" != "xno"; then
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h sys/time.h unistd.h nss.h sys/ioctl.h])
+
+ AC_C_CONST
+ AC_TYPE_SIZE_T
+ AC_HEADER_TIME
+
+ AC_FUNC_MALLOC
+ AC_FUNC_SELECT_ARGTYPES
+ AC_CHECK_FUNCS([gethostbyaddr gethostbyname gettimeofday inet_ntoa memset select socket strcspn strdup strerror strncasecmp strcasecmp strspn])
+
+ have_myhostname=yes
+fi
+AM_CONDITIONAL(HAVE_MYHOSTNAME, [test "$have_myhostname" = "yes"])
+
+# ------------------------------------------------------------------------------
AC_ARG_WITH(firmware-path,
AS_HELP_STRING([--with-firmware-path=DIR[[[:DIR[...]]]]],
[Firmware search path (default=ROOTPREFIX/lib/firmware/updates:ROOTPREFIX/lib/firmware)]),
@@ -835,6 +854,7 @@ AC_MSG_RESULT([
coredump: ${have_coredump}
kmod: ${have_kmod}
blkid: ${have_blkid}
+ nss-myhostname: ${have_myhostname}
gudev: ${enable_gudev}
gintrospection: ${enable_introspection}
keymap: ${enable_keymap}